View Issue Details

IDProjectCategoryView StatusLast Update
0000002Memorandum SeriesMemorandum #1: Keplerian Orbit Elements to Cartesian State Vectorspublic2013-05-01 23:42
ReporteranonymousAssigned ToDigNative 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionwon't fix 
Summary0000002: Memorandum 1, Algorithm step 1, version: 2013/01/30
Description

Hello,

It's Frederic again,

Ithe first step, setting or calculating M(t), the period 86400 s corresponds to the Earth, but a is not given ... In the inputs, as you mentions various possible values for MG = mu, may you give gemeric formulas and set of values (sun, earth, period for a satellite ...)

Best Regards

Frederic Baudrand fbaudrand@free.fr

TagsNo tags attached.

Activities

DigNative

2013-05-01 20:41

administrator   ~0000002

Last edited: 2013-05-01 23:42

Hi Frederic,

thank you for your enhancement request for Memorandum No. 1. As far as I understand there are two points into your request, which I may answer separately:

Conversion of Days to Seconds

The factor $$86\,400$$ in equation 1 for the conversion of Julian days to seconds does not belong to Earth's rotation. This factor is the astronomical unit of time as defined by the IAU (1976) System of Astronomical Constants (1, p. 696). Because neither the initial epoch $$t_0$$ nor the actual computing epoch $$t$$ belong to any celestial body, this factor is independent.

Values for the Standard Gravitational Parameter $$\mu = GM$$

As mentioned in the input section of the algorithm, the Sun is assumed to be the central body for the conversion of Keplerian elements to state vectors. However, if someone want to use another central body, e.g. for calculating the state vectors of a satellite around Earth, he has to supply a value for the standard gravitational parameter of this central body within the desired uncertainty bounds.

Because the values for this standard gravitational parameter are different for each celestial body and --- in general --- this value can not be determined with high certainty, I will just give the current best estimate as published by the IAU Division I Working Group on Numerical Standards for Fundamental Astronomy (2). It is within the responsibility of the user to provide a reliable value for $$\mu$$.

The second part of your point is more general on the nature of $$\mu$$. The standard gravitational parameter $$\mu$$ is used, because the value of $$\mu$$ is known to greater accuracy than the Newtonian constant of gravitation $$G$$ or the mass of the celestial body $$M$$ due to the measurement principle. Because the value of $$\mu$$ is based on observations, I can't give a more general formula for this.

References

  1. Seidelmann, P. Kenneth (ed.): Explanatory Supplement to the Astronomical Almanac. First paperback impression. University Science Books, Sausalito, California, USA, 2006. ISBN 978-1-891389-45-0.
  2. IAU Division I Working Group on Numerical Standards for Fundamental Astronomy: Astronomical Constants: Current Best Estimates (CBEs). Online available at http://maia.usno.navy.mil/NSFA/NSFA_cbe.html#GMS2012. Retrieved 2013/05/01.

Closing Remarks

I hope I could answer your questions/enhancement requests. As I think this was mainly a misunderstanding, I have drawn the conclusion to slightly alter my memorandum to make the discussed things more ostensible. However, since my memoranda are meant to be wrap-ups, not extensive discussions of the related topic, I won't add more explanations to it.

Kind regards,

René

Issue History

Date Modified Username Field Change
2013-04-30 10:35 DigNative New Issue
2013-05-01 20:41 DigNative Assigned To => DigNative
2013-05-01 20:41 DigNative Status new => assigned
2013-05-01 20:41 DigNative Status assigned => resolved
2013-05-01 20:41 DigNative Resolution open => won't fix
2013-05-01 20:41 DigNative Note Added: 0000002
2013-05-01 23:42 DigNative Status resolved => closed